The problem is caused by the fact that the downloaded wav file is missing the length header.
The simplest option is to use an alternate player such as Audacity which can handle these files without a problem.
You can download Audacity from:
http://audacityteam.org/download/
Cause
When using encrypted recordings the Noojee system can never place a decrypted recording on disk.
If Noojee did, this would create a fundamental flaw in our encryption scheme and potentially makes any files that are played accessible to a third party that has compromised your system. (They just have to sit and monitor the 'decrypt' directory.) The entire point of encrypting recordings it to ensure that even if the system is compromised that the hackers will still not have access to the encrypted recordings.
This means that when you want to download a recording Noojee must decrypt and stream the wav files without ever placing the recording file on disk. Streamed wav files do not have a length header which is permitted by the standard. The wav files Noojee generates are valid wav files. The problem is that lots of software such as VLC and Media Player can't deal with wav files that are missing the length header.
Fix the recording
You can also fix the recording so that it will work with your preferred media tool. (Technically this is not a fix as there is nothing actually wrong with the recording.)
The fix is to use a tool to add the header length back into the file after you have downloaded the wav file.
This can be done with sox (a free media tool) and is supported on Windows, OSX and Linux.
http://sourceforge.net/projects/sox/files/sox/
To repair a file run:
sox --ignore-length original.wav fixed.wav
This will result in the file 'fixed.wav' having the correct length header and can then be usable by vlc or media player.